Third-Party Service Disruptions - DNS

Incident Report for FortiSASE

Update

Geoproximity-based DNS resolution continues to recover. Latency for new endpoint connections is improving as PoP assignment stabilizes. We are working with our vendor and monitoring closely.
Posted Mar 18, 2026 - 09:52 UTC

Monitoring

The third-party provider has implemented a fix and we are starting to see successful DNS resolution to allow managed endpoints to connect to their PoPs, with some potential for added latency. We are monitoring the results.
Posted Mar 18, 2026 - 06:18 UTC

Identified

We have identified an issue with a third-party DNS provider that may prevent managed endpoints from connecting to PoPs. Customers may experience degraded or interrupted access during this time. We are actively engaged with the provider and will share updates as soon as they are available.
Posted Mar 18, 2026 - 05:38 UTC

Investigating

We are investigating a widespread 3rd party DNS issue that impacts customers Turbo FQDN unreachable. We are escalating to the 3rd party and will update further information as as soon as possible.


If you have any questions regarding this incident, please contact FortiCare Support (https://www.fortinet.com/support/contact) and reference FortiSASE Operations ticket #457524.
Posted Mar 18, 2026 - 05:03 UTC
This incident affects: FortiSASE Services (Endpoint Management).