Completed
The scheduled maintenance has been completed.
Posted Sep 12, 2025 - 04:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2025 - 20:00 UTC
Scheduled
Anticipated Impact: Potential for short interruption of customer instances and configuration portal during the window.
The Operations team will be installing a rolling software update. There is potential for short connectivity impact (approximately ~1-2 minutes) for each customer instance and the configuration portal while these components are updated. No other impact on service delivery is expected.
Features included in the 25.3.b release include
For Feature release:
Added Feature or Mature tag to the version tooltip at the bottom of the navigation menu.
Added support for highlighting best practices recommendations by displaying an additional prompt upon portal login.
Added support for branch on-ramp with the Standard license for new and upgraded instances. An Advanced branch on-ramp license must also be applied to a Standard instance to enable the branch on-ramp feature.
Added support for simplified branch on-ramp licensing where each on-ramp Security PoP provides up to 1 Gbps for up to 2000 simultaneous dialup IPsec connections, changed from the previous limit of 10 connections. The Branch On-ramp Connection add-on license is discontinued.
Added support for FIDO2 authentication for FortiClient agent tunnels, which is configurable in 'Endpoint profiles' for the 'FortiSASE Cloud Security' tunnel and custom tunnels.
Added support in the AntiVirus security profile for content disarm and reconstruction (CDR) of Microsoft Office documents and PDF files by removing potentially malicious and untrusted content from them.
Added support for configuring and viewing predefined DLP sensors and DLP dictionaries managed by the FortiGuard DLP service in the DLP security profile and in Security > Traffic > Security profiles > Profile resources, respectively.
Added support for displaying IPAM usage information in a chart in Network > IP management > IPAM.
Added support for displaying PoPs on a map during provisioning and after provisioning in Operations > Connectivity > Infrastructure.
For Mature release:
Added Feature or Mature tag to the version tooltip at the bottom of the navigation menu.
Added support for highlighting selected best practices recommendations by displaying an additional prompt upon portal login. For the Mature release, the 'New major features available' best practice has been highlighted.
Added support for branch on-ramp with the Standard license after applying the 'New major features available' best practice to upgrade an existing instance. An Advanced branch on-ramp license must also be applied to a Standard instance to enable the branch on-ramp feature.
Added support for simplified branch on-ramp licensing where each on-ramp Security PoP provides up to 1 Gbps for up to 2000 simultaneous dialup IPsec connections, changed from the previous limit of 10 connections. The Branch On-ramp Connection add-on license is discontinued.
For further information on what's new: https://docs.fortinet.com/document/fortisase/latest/release-notes/661728/whats-new
If you have any questions regarding this maintenance, please contact FortiCare Support (https://www.fortinet.com/support/contact) and reference FortiSASE Operations ticket #384221.
Posted Sep 05, 2025 - 16:17 UTC
This scheduled maintenance affected: Fortinet Cloud Locations (Ashburn, VA, US (IAD-F1), London, United Kingdom (LON-F1), Miami, FL, US (MIA-F1), Ottawa, Canada (YOW-F1), Toronto, Canada (YTO-F1), London, United Kingdom (LON-F2), Miami, FL, US (MIA-F2), Ashburn, VA, US (IAD-F3), London, United Kingdom (LON-F3), Toronto, Canada (YTO-F2), São Paulo (GRU-F1)) and Public Cloud Locations (Santiago, Chile (SCL-G2), Ashburn, VA,US (IAD-G2), Sao Paulo, Brazil (SAO-G2)).